公告ID: KYLIN-2018-16890
安全等级: 中等
产品: Kylin V3
发布日期: 2019年2月6日
CVE: CVE-2018-16890
CVSS3评分: 4.3
概述:
The versions of curl package shipped with Kylin Enterprise Linux 5, 6 and 7 do not support NTLMv2 type-2 headers, hence they are not affected by this flaw. 描述:
libcurl versions from 7.36.0 to before 7.64.0 is vulnerable to a heap buffer out-of-bounds read. The function handling incoming NTLM type-2 messages (`lib/vauth/ntlm.c:ntlm_decode_type2_target`) does not validate incoming data correctly and is subject to an integer overflow vulnerability. Using that overflow, a malicious or broken NTLM server could trick libcurl to accept a bad length + offset combination that would lead to a buffer read out-of-bounds. 系统版本:
KYLIN 3.0.x
KYLIN 3.2.x
KYLIN 3.3.x
受影响包列表:
curl
curl
curl